Suporte Bitrix24

Importante! Possíveis problemas de conexão aos sites e lojas Bitrix24 desde 30 de setembro de 2021

A partir das 17:01 (UTC+3) de 30 de setembro de 2021 os clientes que usam a versão antiga do navegador ou do sistema operacional podem ter problemas com:

  • conexão aos sites e lojas Bitrix24;
  • acesso ás contas com o domínio próprio conectado (plano Professional);
  • execução solicitações API/REST para desde o seu servidor para Bitrix24.

Isso se deve ao fato de que o certificado raiz DST Root CA X3 expirou, mas ele faz parte da cadeia de certificados de cliente de Let's Encrypt que emitimos, e permanecerá até o ano 2024 para suportar os dispositivos Android com as versões 2.3.6-7.1.1.


O que fazer?

A única solução correta é usar software atualizado. Em outras palavras, atualize seus dispositivos e navegadores para as versões mais recentes.

Se você estiver usando o Bitrix Virtual appliance em seu servidor, atualize o pacote ca-certificates usando o seguinte comando:

yum update -y ca-certificates

Se você estiver usando um ambiente de servidor diferente, entre em contato com o administrador do sistema do seu servidor.


Conexão aos sites e contas

O problema não afeta:

  • Windows >= XP SP3 (com atualizações automáticas)
  • macOS >= 10.12.1
  • iOS >= 10
  • Android >= 7.1.1
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial / 16.04 (com atualizações)
  • Debian >= jessie / 8 (com atualizações)
  • Java 8 >= 8u141
  • Java 7 >= 7u151
A operação dos navegadores Chrome, Safari, Edge, Opera, Vivaldi vai depender da versão do sistema operacional em que estão instalados.

Em todos os outros casos, pode haver problemas com a conexão, será exibido o erro de a expiração dos certificados ao entrar nos sites Bitrix24, lojas on-line e contas com domínio próprio.


Execução de solicitações REST/API

Principalmente, isso vai afetar os clientes que fazem solicitações API dos servidores com software desatualizado que usam:

  • openssl-1.0.1 – completamente incompatível e não funcionará sem recolher seus próprios pacotes (CentOS 6).
  • openssl-1.0.2 – é necessário atualizar o pacote ca-certificates nos servidores (CentOS 7).
  • openssl-1.1.x – totalmente compatível.

Para resolver esse inconveniente, entre em contato com o administrador do sistema do seu servidor.


Pode ler mais detalhadamente sobre a compatibilidade de certificado raiz DST Root CA X3 com dispositivos e sistemas operacionais na documentação do Let's Encrypt.


Isso ajudou
Obrigado :)
Opcional:
Deixar comentário sobre o artigo
Isso não ajudou
Desculpa :(
Você poderia nos dizer por que:
Deixar comentário sobre o artigo
Eu ainda tenho dúvidas